Múltiples vulnerabilidades en gzip de Sun Solaris 8, 9 y 10



Sun reconoce múltiples problemas en gzip que pueden provocar la ejecución de código arbitrario o denegación de servicio. La firma acaba de publicar los parches para esta vulnerabilidad.

Se han detectado múltiples problemas en gzip que pueden permitir a un atacante local o remoto sin privilegios, ejecutar código arbitrario con los privilegios de otro usuario que utilice el comando gzip o provocar una denegación de servicio a través de un archivo gzip especialmente manipulado.

Entr las vulnerabilidades corregidas:

* Un desbordamiento de memoria intermedia en la función make_table en el componente LHZ puede llevar a la ejecución de código arbitrario a través de una tabla de decodificación especialmente manipulada en un archivo gzip.

* Denegación de servicio a través de unlzh.c en el componente LHZ.

* Desbordamiento de memoria intermedia en la función build_tree en unpack.c permite ejecución de código.

* Error de índices de array en la función make_table en unlzh.c en el componente LZH, bajo ciertas plataformas, permite provocar una denegación de servicio y potencialmente ejecución de código.

* Referencia de puntero a nul a través de una vulnerabilidad no especificada permite provocar denegaciones de servicio con un archivo gzip especialmente manipulado.

Según versión y plataforma, las actualizaciones están disponibles
desde:

Para SPARC:

Para Solaris 9 instalar 116340-06 desde
#116340-06: SunOS 5.9: gzip and Freeware info files patch
o posterior

Para Solaris 10 instalar 120719-02 desde
#120719-02: SunOS 5.10 : SunFreeware gzip patch
o posterior

Para x86:

Para Solaris 9 instalar 116341-06 desde
#116341-06: SunOS 5.9_x86: gzip and Freeware info files patch
o posterior

Para Solaris 10 instalar 120720-02 desde
#120720-02: SunOS 5.10_x86 : SunFreeware gzip patch
o posterior


Fuente: Hispasec - Seguridad Informática.