• Registrarse
  • Iniciar sesión


  • Página 1 de 2 12 ÚltimoÚltimo
    Resultados 1 al 10 de 17

    Bug en Opera 9.02 deja el procesador al 99%

    Bug en Opera 9.02 deja el procesador al 99% Navegando un poco por la red me encuentro con un articulo "descubrimiento" del amigo Bernardo Quintero de Hispasec , donde comente un simple manera de provocar ...

          
    1. #1
      FS-Admin
      Avatar de @MarceloRivero
      Registrado
      ene 2005
      Ubicación
      Miami
      Mensajes
      40.915

      Atención Bug en Opera 9.02 deja el procesador al 99%

      Bug en Opera 9.02 deja el procesador al 99%

      Navegando un poco por la red me encuentro con un articulo "descubrimiento" del amigo Bernardo Quintero de Hispasec, donde comente un simple manera de provocar un DoS en el navegador de internet Opera 9.02 (y algunas versiones anteriores).

      Básicamente se trata de que con solo visitar cualquier URL poniendo http:/// (con 3 barras, en lugar de dos) Opera consume todo el CPU y poco a poco también se va consumiendo la memoria RAM con el consecuente cuelgue del navegador y degradado del sistema.

      Este bug fue detectado en Opera 9.02 compilación 8585 bajo Windows XP (ambos últimas versiones y actualizados).

      En otras pruebas realizadas con un portátil AMD Turión, el bug provoca un consumo de CPU que ronda entre el 90-99% y la degradación del sistema es más evidente.

      Bajo Linux este bug también esta presente pero ya dejando el consumo del CPU al 50% y no consumiendo la memoria RAM

      En Internet Explorer y Firefox, como es de esperar, simplemente da un mensaje de que la dirección no es válida. En cuanto a la explotación remota, podría hacerse a través de un enlace, un frame, etc., realmente no tiene mucho sentido, es un bug bastante "tonto", aunque ya su descubridor se lo a reportado a Opera para que lo corrijan en su próxima versión.

      Para los usuarios de Opera que quieran hacer de BetaTesters y confirmar el bug. Ya saben que basta con introducir la URL http:/// en la dirección del navegador, y darle >Enter> para luego contarnos que ocurre en este mismo mensaje.

      No olviden de comentar su versión de Opera y la configuración de su sistema.

      Marcelo Rivero
      Microsoft MVP Enterprise Security.



      * Síguenos en nuestro Twitter y hazte nuestro amigo en Facebook.
      * Infórmate de las ultimas amenazas de la red desde: InfoSpyware Blog
      * No se resuelven dudas por Privados ni por E-mail, ya que para eso esta el foro.

    2. #2
      FS-Admin
      Avatar de @MarceloRivero
      Registrado
      ene 2005
      Ubicación
      Miami
      Mensajes
      40.915

      Re: Bug en Opera 9.02 deja el procesador al 99%

      Eh probado el nuevo bug personalmente en mi Laptop donde aparte de mi amado "Firefox " también tengo la ultima versión de Opera 9.02 y estos fueron los resultados:

      El Sistema:
      Cetrino Core 2 Duo
      2 GB RAM
      Win XP SP2
      Opera 9.02

      El Resultado con http:///
      CPU - Aumento automático al 50%
      RAM - Sin consumo excesivo de memoria.
      SO - Sin problemas aparentes.
      Opera - Freezado hasta abrir un nuevo link, pero sin mayores inconvenientes en volver a recuperar el sistema.

      A ver quien mas se anima a reportar este bug....

      SAlu2
      Marcelo Rivero
      Microsoft MVP Enterprise Security.



      * Síguenos en nuestro Twitter y hazte nuestro amigo en Facebook.
      * Infórmate de las ultimas amenazas de la red desde: InfoSpyware Blog
      * No se resuelven dudas por Privados ni por E-mail, ya que para eso esta el foro.

    3. #3
      Usuario Avatar de dmassive
      Registrado
      may 2006
      Ubicación
      Argentina
      Mensajes
      1

      Investigación Re: Bug en Opera 9.02 deja el procesador al 99%

      Lo probe... consumo 99%, y quedo inutilizable. No quedo otra que terminar el proceso :( y uso opera como mi navegador primario.

      Sistema:
      Athlon64 3200+ Venice
      2 GB RAM
      Win XP SP2
      Opera 9.02.8585
      Última edición por dmassive fecha: 09/11/06 a las 12:25:31

    4. #4
      Ex-Colaborador Avatar de Acron_0248
      Registrado
      jul 2005
      Ubicación
      127.0.0.1
      Mensajes
      9.734

      Re: Bug en Opera 9.02 deja el procesador al 99%

      Bueno, como usuario Opera, me toca dejar mis resultados acá:

      Sistema:

      Intel PIV 1.5 Ghz
      512 MB de ram
      Windows XP SP2
      Opera 9.02 (Build 8585)

      Luego de colocar la url 'http:///' se cambió la url a 'http:/' y el proceso Opera.exe iba entre 90-99% manteniéndose en 99% luego de unos 5 o 7 segundos tal y como se aprecia en la captura de abajo:




      Aún así, el navegador no quedó completamente inútil, de hecho, igual podía trabajar con él y para cancelar el proceso, solo tuve que darle click a la " X " roja para detener la petición hacia http. La ram no se vió afectada por el consumo del opera, tal y como se ve en la imagen de abajo, se mantuvo estable durante el tiempo que mantuve ejecutando el opera:




      Mi otra prueba:

      Gentoo Linux
      Opera 9.02 (Build 434)

      El procesador se mantuvo al 99%, la memoria se mantuvo estable, al igual que en windows, tampoco fue consumida y el navegador tampoco estuvo completamente bloqueado






      Salu2
      Linux User #399288 != 1337 || Ub3|2

      Novedades del Foro | Antivirus Online | Eliminar Malwares | Políticas del Foro | Blog


      * Ayúdanos haciendo una DONACIÓN para poder seguir Ayudando.
      * Infórmate de las ultimas amenazas de la red desde: InfoSpyware Blog
      * No se resuelven dudas por Privados ni por E-mail, ya que para eso esta el foro.

    5. #5
      Usuario Avatar de herxux
      Registrado
      ago 2006
      Ubicación
      andorra
      Mensajes
      13

      Re: Bug en Opera 9.02 deja el procesador al 99%

      Probado (..o mejor dicho... sufrido ) el problema, me encuentro que poco a poco pierde agilidad i al cargar el correo on line con algun adjunto de mediano peso, no consiente la carga i Opera me lanza un mensaje de cierre de navegador. Igual que cuando descargo.
      En uso CPU no me sube más allá del 10%, pero poco a poco sube la utilizacion de ram, hasta más allá de 60.000 KB antes de echar-me fuera
      Sistema:
      Athlon 64 3000+ S939
      1024 MB ram
      Opera 9.02 V 8585

      Saludos

    6. #6
      Baneado Avatar de Mario Bros.
      Registrado
      jul 2006
      Ubicación
      Ciudad Autónoma De Buenos Aires, Argentina
      Mensajes
      325

      Molesto Re: Bug en Opera 9.02 deja el procesador al 99%

      hola!

      probe con lo del http:/// y si, paso lo que dijeron, pero solo llego al 98% de consumo de cpu y 38.076 kb de uso de memoria.



      Sistema

      Amd Sempron 2800+ S754
      448 RAM
      Windows XP Professional Service Pack 2
      Opera 9.02 (Build 8585)


      saludos
      Última edición por Mario Bros. fecha: 05/01/07 a las 12:37:34

    7. #7
      Ex-Colaborador Avatar de GuillermoTell
      Registrado
      abr 2006
      Ubicación
      Colombia
      Mensajes
      8.100

      Bien Re: Bug en Opera 9.02 deja el procesador al 99%

      Que tal, aca estan los datos de mi PC.

      Windows XP SP2
      Atlhon XP 2400+
      512 Mb Ram
      Opera 9.10

      Bueno estos son los datos de mi prueba.

      Uso de CPU se disparo al 99% pero lo raro es que la primera vez que probé el bug me pareció que la ram disminuyo dramáticamente, pero como tenia otros programas abiertos decidí reiniciar el ordenador y probarlo solo con el Opera abierto. Pero en este intento por el contrario paso de 201 Mb de Ram con el Opera abierto, 237 Mb de RAm con el bug y uso de cpu al 99% y por ultimo al cerrar el Opera 260Mb de Ram.
      Última edición por GuillermoTell fecha: 05/01/07 a las 12:51:58 Razón: Version incorrecta del navegador

    8. #8
      Baneado Avatar de Mario Bros.
      Registrado
      jul 2006
      Ubicación
      Ciudad Autónoma De Buenos Aires, Argentina
      Mensajes
      325

      Re: Bug en Opera 9.02 deja el procesador al 99%

      Hola!!

      Probé el Bug en el nuevo Opera 9.10 (Build 8679) y esto fue lo que paso:



      Pasa lo mismo con la ultima version de opera, espero que solucionen este problema en la otra versión o que lanzen un parche para solucionarlo.


      Sistema

      Amd Sempron 2800+ S754
      448 RAM
      Windows XP Professional Service Pack 2
      Opera 9.10 (Build 8679)


      Saludos
      Última edición por Mario Bros. fecha: 05/01/07 a las 12:48:58

    9. #9
      Usuario Avatar de augusto87
      Registrado
      jun 2006
      Ubicación
      Venezuela
      Mensajes
      137

      Re: Bug en Opera 9.02 deja el procesador al 99%

      y porque utilizan esta version??? acaso ustedes son masoquistas...

      Existe una version mas nueva que es la 9.10...yo la uso y me va de mil maravillasss...........

    10. #10
      Baneado Avatar de Mario Bros.
      Registrado
      jul 2006
      Ubicación
      Ciudad Autónoma De Buenos Aires, Argentina
      Mensajes
      325

      Re: Bug en Opera 9.02 deja el procesador al 99%

      sory, no habia entendido el msj.

      la ultima version es la 9.10, no?

      saludos

    Página 1 de 2 12 ÚltimoÚltimo