Se han encontrado vulnerabilidades en Adoble Flash Player Plugin que permiten a un atacante remoto inyectar cabeceras HTTP arbitrarias.

El fallo se produce al llamar a la función addRequestHeader especialmente manipulada. Un atacante podría añadir valores arbitrarios en las cabeceras de una petición Flash HTTP.

Un atacante también podría proporcionar valores especialmente manipulados al atributo contentType para establecer valores arbitrarios en una petición Flash HTTP.

Esto permitiría a un atacante perpetrar ataques de cross site scripting, falsificaciones de peticiones y robar información sensible. Se ven afectadas todas las versiones de Flash Player para plataformas Windows y Linux, hasta la 9.0.16 para Windows y la 7.0.63 para Linux.

La beta 9.0.18d60 para Windows no se ve afectada por este problema.



Más información:

Adobe Flash Player Plugin Lets Remote Users Injection Arbitrary HTTP Header Data httphttp://securitytracker.com/alerts/2006/Oct/1017078.html

HTTP header injection vulnerabilities in Adobe Flash Player
http://www.adobe.com/support/security/advisories/apsa06-01.html